# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\d+[a-z]|[a-z]+\d)[a-z\d]*//gm;t' <<< "asdasdas7
7sdfdf
a1
1a
0001a
0000a0000
a-1
1-a
a
1
eee
21123124
aaaa-111
1 a 6858 ghg 8768-zzt zz zt t-3
1212231234_sdfs1111dfsdf_ewrwerfwe_sef3325345"