#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\d+[a-z]|[a-z]+\d)[a-z\d]*"
Local $sString = "asdasdas7" & @CRLF & _
"7sdfdf" & @CRLF & _
"a1" & @CRLF & _
"1a" & @CRLF & _
"0001a" & @CRLF & _
"0000a0000" & @CRLF & _
"a-1" & @CRLF & _
"1-a" & @CRLF & _
"a" & @CRLF & _
"1" & @CRLF & _
"eee" & @CRLF & _
"21123124" & @CRLF & _
"aaaa-111" & @CRLF & _
"1 a 6858 ghg 8768-zzt zz zt t-3" & @CRLF & _
"1212231234_sdfs1111dfsdf_ewrwerfwe_sef3325345"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)