import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d+[a-z]|[a-z]+\\d)[a-z\\d]*";
final String string = "asdasdas7\n"
+ "7sdfdf\n"
+ "a1\n"
+ "1a\n"
+ "0001a\n"
+ "0000a0000\n"
+ "a-1\n"
+ "1-a\n"
+ "a\n"
+ "1\n"
+ "eee\n"
+ "21123124\n"
+ "aaaa-111\n"
+ "1 a 6858 ghg 8768-zzt zz zt t-3\n"
+ "1212231234_sdfs1111dfsdf_ewrwerfwe_sef3325345";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}