use strict;
my $str = 'asdasdas7
7sdfdf
a1
1a
0001a
0000a0000
a-1
1-a
a
1
eee
21123124
aaaa-111
1 a 6858 ghg 8768-zzt zz zt t-3
1212231234_sdfs1111dfsdf_ewrwerfwe_sef3325345';
my $regex = qr/(?:\d+[a-z]|[a-z]+\d)[a-z\d]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";