// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+) (\w+) (\w+) (\w+)").unwrap();
let string = "First Letter Is Uppercase";
let substitution = "\\l$1 $2 $3 $4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}