import Foundation
let pattern = #"(\w+) (\w+) (\w+) (\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"First Letter Is Uppercase"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\l$1 $2 $3 $4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)