const regex = /(?:^|\s)
(\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b)
(?:$|\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)
(\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b
\\.
\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b
\\.
\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b
\\.
\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b)
(?:$|\\s)', 'gm')
const str = `0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}