re = /(?:^|\s)
(\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b)
(?:$|\s)/mx
str = '0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end