import re
regex = re.compile(r"""
(?:^|\s)
(\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b)
(?:$|\s)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("0.0.0.0\n"
"192.168.1.1\n"
"127.0.0.1\n"
"255.255.255.255\n\n\n"
"256.0.0.0\n"
"0.256.0.0\n"
"0.0.256.0\n"
"0.0.0.256\n"
".0.0.0.0\n"
"0.0.0.0.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")