// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?:^|\s)
(\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b)
(?:$|\s)").unwrap();
let string = "0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}