using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<body([^>]*)>";
string substitution = @"'<body$1><div id=""root"">'";
string input = @"<body class=""blah blah"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}