use strict;
my $str = '<body class="blah blah">';
my $regex = qr/<body([^>]*)>/p;
my $subst = '\'<body$1><div id="root">\'';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";