import Foundation
let pattern = #"<body([^>]*)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<body class="blah blah">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'<body$1><div id="root">'"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}