// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<body([^>]*)>").unwrap();
let string = "<body class=\"blah blah\">";
let substitution = "'<body$1><div id=\"root\">'";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}