const regex = /<body([^>]*)>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<body([^>]*)>', '')
const str = `<body class="blah blah">`;
const subst = `'<body$1><div id="root">'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);