#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^\d\.]"
Local $sString = "160 612.81 руб"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)