use strict;
my $str = '160 612.81 руб';
my $regex = qr/[^\d\.]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";