package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d\.]`)
var str = `160 612.81 руб`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}