import Foundation
let pattern = #"[^\d\.]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"160 612.81 руб"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)