const regex = /[^\d\.]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\d\\.]', 'g')
const str = `160 612.81 руб`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);