$re = '/[^\d\.]/';
$str = '160 612.81 руб';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;