#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sU)\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}"
Local $sString = "{\added[id=JK]{$\dfrac{\bigg(\dfrac{x^2}{y}\bigg)^3x^{-2}}{xy^2}$}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")