const regex = /\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\added\\[.*\\]\\{(.*(?:\\{.*\\}.*)*)\\}', 's')
const str = `{\\added[id=JK]{\$\\dfrac{\\bigg(\\dfrac{x^2}{y}\\bigg)^3x^{-2}}{xy^2}\$}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}