import re
regex = re.compile(r"\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}", flags=re.DOTALL)
test_str = "{\\added[id=JK]{$\\dfrac{\\bigg(\\dfrac{x^2}{y}\\bigg)^3x^{-2}}{xy^2}$}"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")