use strict;
my $str = '{\\added[id=JK]{$\\dfrac{\\bigg(\\dfrac{x^2}{y}\\bigg)^3x^{-2}}{xy^2}$}';
my $regex = qr/\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}