re = /\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}/
str = '{\\added[id=JK]{$\\dfrac{\\bigg(\\dfrac{x^2}{y}\\bigg)^3x^{-2}}{xy^2}$}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end