$re = '/\\\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}/sU';
$str = '{\\added[id=JK]{$\\dfrac{\\bigg(\\dfrac{x^2}{y}\\bigg)^3x^{-2}}{xy^2}$}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);