#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "ERROR\s-[\s]*Method:\s([\w.$]+\([\w.$]*)[,|\)]"
Local $sString = "INFO - converting to dex: de.devmil.minimaltext-dex2jar.jar ..." & @CRLF & _
"INFO - loading ..." & @CRLF & _
"INFO - processing ..." & @CRLF & _
"ERROR - Inconsistent code in method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean" & @CRLF & _
"ERROR - Inconsistent code in method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int" & @CRLF & _
"ERROR - Inconsistent code in method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void" & @CRLF & _
"ERROR - 3 errors occurred in following nodes:" & @CRLF & _
"ERROR - Method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int" & @CRLF & _
"ERROR - Method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean" & @CRLF & _
"ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void" & @CRLF & _
"ERROR - finished with errors" & @CRLF & _
"ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")