import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ERROR\\s-[\\s]*Method:\\s([\\w.$]+\\([\\w.$]*)[,|\\)]";
final String string = "INFO - converting to dex: de.devmil.minimaltext-dex2jar.jar ...\n"
+ "INFO - loading ...\n"
+ "INFO - processing ...\n"
+ "ERROR - Inconsistent code in method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean\n"
+ "ERROR - Inconsistent code in method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int\n"
+ "ERROR - Inconsistent code in method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void\n"
+ "ERROR - 3 errors occurred in following nodes:\n"
+ "ERROR - Method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int\n"
+ "ERROR - Method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean\n"
+ "ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void\n"
+ "ERROR - finished with errors\n"
+ "ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate()";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}