import re
regex = re.compile(r"ERROR\s-[\s]*Method:\s([\w.$]+\([\w.$]*)[,|\)]")
test_str = ("INFO - converting to dex: de.devmil.minimaltext-dex2jar.jar ...\n"
"INFO - loading ...\n"
"INFO - processing ...\n"
"ERROR - Inconsistent code in method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean\n"
"ERROR - Inconsistent code in method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int\n"
"ERROR - Inconsistent code in method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void\n"
"ERROR - 3 errors occurred in following nodes:\n"
"ERROR - Method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int\n"
"ERROR - Method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean\n"
"ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void\n"
"ERROR - finished with errors\n"
"ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate()")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")