$re = '/ERROR\s-[\s]*Method:\s([\w.$]+\([\w.$]*)[,|\)]/';
$str = 'INFO - converting to dex: de.devmil.minimaltext-dex2jar.jar ...
INFO - loading ...
INFO - processing ...
ERROR - Inconsistent code in method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean
ERROR - Inconsistent code in method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int
ERROR - Inconsistent code in method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void
ERROR - 3 errors occurred in following nodes:
ERROR - Method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int
ERROR - Method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean
ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void
ERROR - finished with errors
ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);