use strict;
my $str = 'INFO - converting to dex: de.devmil.minimaltext-dex2jar.jar ...
INFO - loading ...
INFO - processing ...
ERROR - Inconsistent code in method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean
ERROR - Inconsistent code in method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int
ERROR - Inconsistent code in method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void
ERROR - 3 errors occurred in following nodes:
ERROR - Method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int
ERROR - Method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean
ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void
ERROR - finished with errors
ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate()';
my $regex = qr/ERROR\s-[\s]*Method:\s([\w.$]+\([\w.$]*)[,|\)]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}