package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ERROR\s-[\s]*Method:\s([\w.$]+\([\w.$]*)[,|\)]`)
var str = `INFO - converting to dex: de.devmil.minimaltext-dex2jar.jar ...
INFO - loading ...
INFO - processing ...
ERROR - Inconsistent code in method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean
ERROR - Inconsistent code in method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int
ERROR - Inconsistent code in method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void
ERROR - 3 errors occurred in following nodes:
ERROR - Method: de.devmil.minimaltext.billing.IabHelper.queryPurchases(de.devmil.minimaltext.billing.Inventory, java.lang.String):int
ERROR - Method: de.devmil.minimaltext.data.battery.BatteryData.equals(java.lang.Object):boolean
ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate(boolean):void
ERROR - finished with errors
ERROR - Method: de.devmil.minimaltext.weather.WeatherUpdateService.doUpdate()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}