import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([-0-9a-zA-Z.+_]+\\s?(?:@|\\(at\\)|\\|at\\||\\(@\\))\\s?+[-0-9a-zA-Z.+_]+(?:\\.|\\(Dot\\))(?:de|com|net|org))";
final String string = "text@text(Dot)de\n"
+ "text(@)text(Dot)de\n"
+ "text(at)text(Dot)de\n"
+ "text|at|text(Dot)de\n\n"
+ "text@text.de\n"
+ "text(@)text.de\n"
+ "text(at)text.de\n"
+ "text|at|text.de\n\n"
+ "text @ text.de\n"
+ "text (@) text.de\n"
+ "text (at) text.de\n"
+ "text |at| text.de";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}