#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^-a-z0-9\/]+"
Local $sString = "asdkf" & @CRLF & _
"43435&$*k((/\"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)