import Foundation
let pattern = #"[^-a-z0-9\/]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
asdkf
43435&$*k((/\
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)