$re = '/[^-a-z0-9\/]+/';
$str = 'asdkf
43435&$*k((/\\';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;