use strict;
my $str = 'asdkf
43435&$*k((/\\';
my $regex = qr/[^-a-z0-9\/]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";