using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"com/vessels\?page=\d+";
string input = @"com/vessels?page=2
com/vessels?page=20
com/vessels?page=100
com/vessels?page=101";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}