re = /com\/vessels\?page=\d+/
str = 'com/vessels?page=2
com/vessels?page=20
com/vessels?page=100
com/vessels?page=101'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end