package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`com/vessels\?page=\d+`)
var str = `com/vessels?page=2
com/vessels?page=20
com/vessels?page=100
com/vessels?page=101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}