import re
regex = re.compile(r"com/vessels\?page=\d+")
test_str = ("com/vessels?page=2\n"
"com/vessels?page=20\n"
"com/vessels?page=100\n"
"com/vessels?page=101")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")