$re = '/com/vessels\?page=\d+/';
$str = 'com/vessels?page=2
com/vessels?page=20
com/vessels?page=100
com/vessels?page=101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);