// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"com/vessels\?page=\d+").unwrap();
let string = "com/vessels?page=2
com/vessels?page=20
com/vessels?page=100
com/vessels?page=101";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}