#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(?[1-9]{2}\)?( ?)?([1-9]{1}[0-9]{3}|[0-9]{3}) ?[0-9]{4}$"
Local $sString = "(98) 9 8111 2233" & @CRLF & _
"(98) 98111 2233" & @CRLF & _
"(98) 981112233" & @CRLF & _
"(98)981112233" & @CRLF & _
"(98)9 8111 2233" & @CRLF & _
"(98)9 81112233" & @CRLF & _
"(98) 981112233" & @CRLF & _
"(98) 2222 3333" & @CRLF & _
"(98) 22223333" & @CRLF & _
"(98)22223333" & @CRLF & _
"98 9 8111 2233" & @CRLF & _
"98 98111 2233" & @CRLF & _
"98 981112233" & @CRLF & _
"98981112233" & @CRLF & _
"989 8111 2233" & @CRLF & _
"989 81112233" & @CRLF & _
"98 981112233" & @CRLF & _
"98 2222 3333" & @CRLF & _
"98 22223333" & @CRLF & _
"9822223333" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")