// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\(?[1-9]{2}\)?( ?)?([1-9]{1}[0-9]{3}|[0-9]{3}) ?[0-9]{4}$").unwrap();
let string = "(98) 9 8111 2233
(98) 98111 2233
(98) 981112233
(98)981112233
(98)9 8111 2233
(98)9 81112233
(98) 981112233
(98) 2222 3333
(98) 22223333
(98)22223333
98 9 8111 2233
98 98111 2233
98 981112233
98981112233
989 8111 2233
989 81112233
98 981112233
98 2222 3333
98 22223333
9822223333
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}