package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(?[1-9]{2}\)?( ?)?([1-9]{1}[0-9]{3}|[0-9]{3}) ?[0-9]{4}$`)
var str = `(98) 9 8111 2233
(98) 98111 2233
(98) 981112233
(98)981112233
(98)9 8111 2233
(98)9 81112233
(98) 981112233
(98) 2222 3333
(98) 22223333
(98)22223333
98 9 8111 2233
98 98111 2233
98 981112233
98981112233
989 8111 2233
989 81112233
98 981112233
98 2222 3333
98 22223333
9822223333
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}