# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\(?[1-9]{2}\)?( ?)?([1-9]{1}[0-9]{3}|[0-9]{3}) ?[0-9]{4}$"
test_str = ("(98) 9 8111 2233\n"
"(98) 98111 2233\n"
"(98) 981112233\n"
"(98)981112233\n"
"(98)9 8111 2233\n"
"(98)9 81112233\n"
"(98) 981112233\n"
"(98) 2222 3333\n"
"(98) 22223333\n"
"(98)22223333\n"
"98 9 8111 2233\n"
"98 98111 2233\n"
"98 981112233\n"
"98981112233\n"
"989 8111 2233\n"
"989 81112233\n"
"98 981112233\n"
"98 2222 3333\n"
"98 22223333\n"
"9822223333\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.