import Foundation
let pattern = #"^\(?[1-9]{2}\)?( ?)?([1-9]{1}[0-9]{3}|[0-9]{3}) ?[0-9]{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(98) 9 8111 2233
(98) 98111 2233
(98) 981112233
(98)981112233
(98)9 8111 2233
(98)9 81112233
(98) 981112233
(98) 2222 3333
(98) 22223333
(98)22223333
98 9 8111 2233
98 98111 2233
98 981112233
98981112233
989 8111 2233
989 81112233
98 981112233
98 2222 3333
98 22223333
9822223333
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)