import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?[1-9]{2}\\)?( ?)?([1-9]{1}[0-9]{3}|[0-9]{3}) ?[0-9]{4}$";
final String string = "(98) 9 8111 2233\n"
+ "(98) 98111 2233\n"
+ "(98) 981112233\n"
+ "(98)981112233\n"
+ "(98)9 8111 2233\n"
+ "(98)9 81112233\n"
+ "(98) 981112233\n"
+ "(98) 2222 3333\n"
+ "(98) 22223333\n"
+ "(98)22223333\n"
+ "98 9 8111 2233\n"
+ "98 98111 2233\n"
+ "98 981112233\n"
+ "98981112233\n"
+ "989 8111 2233\n"
+ "989 81112233\n"
+ "98 981112233\n"
+ "98 2222 3333\n"
+ "98 22223333\n"
+ "9822223333\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}